User Login    
 + Register
  • Main navigation
Login
Username:

Password:


Lost Password?

Register now!
Fast Search
Slow Search
Google Ad



Main : Members : steveo Gx motor

[<   Previous  5  6  7  8  9  10  11  Next   >]

Gx motor
Gx motorPopular
SubmittersteveoMore Photos from steveo   Last Update2008/11/5 4:11    Tell a friendTell a friend
Hits2852  Comments7    0.00 (0 votes)0.00 (0 votes)
For thread

[<   Previous  5  6  7  8  9  10  11  Next   >]

The comments are owned by the poster. We aren't responsible for their content.

Poster Thread
ddgonzal
Posted: 2009/3/15 4:22  Updated: 2009/3/15 4:22
Moderator
Joined: 2001/5/3
From: Hawaii, USA
Posts: 30803
 Re: Gx motor
Looks like A12T engine. Nice.

Poster Thread
datto1000wagon
Posted: 2009/3/15 4:33  Updated: 2009/3/15 4:33
No life (a.k.a. DattoMaster)
Joined: 2006/5/2
From: Darwin NT
Posts: 2080
 Re: Gx motor
wheres the coolant holes?
that rocker cover isnt a genuine gx item either
i suspect this motor may not be a gx

Poster Thread
clyons8
Posted: 2009/3/15 5:45  Updated: 2009/3/15 5:45
No life (a.k.a. DattoMaster)
Joined: 2007/1/22
From: East New Britain, Papua New Guinea
Posts: 6994
 Re: Gx motor
It was for sale in classifieds a while ago as a GX, you two along with dodgeman confirmed it not to be a gx engine.

Poster Thread
conehead
Posted: 2009/3/15 5:48  Updated: 2009/3/15 5:48
Home away from home
Joined: 2008/4/25
From: Melbourne vic
Posts: 670
 Re: Gx motor
Looks loke a late centre dizzy block?

Poster Thread
datto1000wagon
Posted: 2009/3/15 7:08  Updated: 2009/3/15 7:08
No life (a.k.a. DattoMaster)
Joined: 2006/5/2
From: Darwin NT
Posts: 2080
 Re: Gx motor
yes i was going to say it could be a raised port race head but this pic confirms it is not

perhaps it is a gx and has had the coolant holes welded up?

Poster Thread
conehead
Posted: 2009/3/15 7:29  Updated: 2009/3/15 7:29
Home away from home
Joined: 2008/4/25
From: Melbourne vic
Posts: 670
 Re: Gx motor
Thats an interesting photo, the casting
marks suggest Gx, and even though there
is a lack of water ports could they have
been blocked off or something!!!

edit (as 1000wgn suggests!!)